Description of Issue

The “Please Close Cover” message appears once the project begins even though the cover is closed.  The machine has two switches that check to see that the cover is down before cutting.  The left one reports the cover state to the electronics and the right one connects the power circuit to the cut motor which allows it to run when the cover is down.  If the left one is not showing “Closed” then the machine will show this message.

Possible Causes

Causes include: a faulty cover switch (or full of dust), a loose cover or switch, a bent cover that does not allow the cover to fully actuate the switch, or a disconnected cover cable on the head termination board (seen especially right after servicing where the cover was removed).

Troubleshooting Steps

  1. Check the state of the cover switch in the sensor check menu.  Turn the machine ON and navigate to the Configurations Menu from the CarveWright Main Menu by using the up/down arrows or pressing the “0” (Options) key on the keypad.  Navigate to, or select key “7”, Sensor Check.  Use the up/down arrows to find menu items titled Cover Switch.  With the cover up it should say “Open” and with the cover closed it should say “Closed”.  Open and close the cover and see if the switch changes state for “Open” to “Closed”.
  2. Check that the left cover hinge cover is not loose and that the switch is not loose.  If either is loose it can affect the actuation of the switch button by the finger on the clear cover.
  3. Verify that the connectors to the switch are in place and tight.
  4. Take a small implement and manually depress the switch button by hand.  If you can get the LCD to switch to “Closed” then there is something wrong with the cover that is preventing it from depressing the switch far enough.  Resolve this cover issue.
  5. Also listen for a clicking sound as you depress the switch by hand.  If the connector is seated and the clicking can be heard without the cover showing “Closed” then most likely the switch has dust in it or is bad.  Blow out the switch and test again.
  6. If the error occurs during carving then check the cover engagement with the switch.  It is possible that the vibration lifts the cover enough to release the switch momentarily.  In this case it usually happens with regularity.  Adjust the cover so that the switch engagement is positive
  7. If the machine has recently been serviced and the cover was removed it is very possible that the switch cable was not plugged in correctly.  Verify that the cover cable is correctly plugged into the head termination board.  Unplug and re-plug if the seating is unsure.
  8. If none of the above steps solves the issue consult a senior engineer.