Instructions for products purchased from our ONLINE STORE including:

Add-On Software · Patterns · Pattern Collections · Projects · Subscriptions


NOTE: If you are looking for help with Activation, Download, Installation, Registration or Re-Registration of Designer Software 1.18x or 2.00x, or 3.00x, click this link: Designer Software Setup


EXPLANATION OF ACTIVATION, DOWNLOAD & INSTALL:

One or all of the following steps may be necessary, depending on which product you purchased.

ACTIVATION is required for all of these products and done with a special activation code or Serial # and stored in your Customer Account. Here are some more facts about activation:

  • Activation Codes are sometimes referred to as registration or license codes or serial #‘s.
  • They are usually sent to you as part of your invoice via the email address on your Store Account.
  • The email will come to you within a few minutes, but should not take over 24 hours.
  • You may also be able to log into your Store Account History to find these codes.
  • If you ordered a Scanning Probe or Keyhole Bit, the activation codes for their software will come with the physical items when shipped.
  • The code starts AFTER the colon (:). It’s format includes both letters and number in sets of 4 separated by a decimal point (XXXX.XXXX.XXXX.XXXX) The letters are case sensitive and decimal points are required.
  • Codes are activated to your Customer Account, where you manage your licenses.
  • Licenses can be activated to a Customer Account either via the Designer Software (prefered) or through the CarveWright Website.
  • Customers using Windows Vista, 7 or 8 must use the RUN AS ADMINISTRATOR command when opening their Designer software by right-clicking on the icon and selecting RUN AS ADMINISTRATOR when activating a license code.
  • Codes are activated only once! You will never activate it, again.
  • Thereafter, they can be applied to any of your registered computers.
  • Patterns that have NOT been activated, but are already downloaded into your Pattern Library will have red background.
  • If you have activated your license code, but it only shows as an * in the tabs of your INSTALLED LICENSES window, that indicates you need a newer version of the software.
  • You can look in your Manage Licenses under HELP in the software to see your activations.
  • Or log into your Customer Account HERE.

DOWNLOAD may be required, if there is a file that needs to be downloaded from our website. Here are some facts about downloads:

  • Downloads can be many different types of files, such as the Designer Software (.exe), patterns (.ptn), collections (.mpn) or projects (.zip). Free Unzip Software is available online.
  • If you have purchased an Advanced Software Feature and ALREADY HAVE THE LATEST VERSION INSTALLED, then you DO NOT need to redownload Designer.
  • These will usually go into your computers DOWNLOADS folder unless you direct it to a different SAVE location.
  • There are several ways to download a file:
    • A download link will be sent to you via email after the purchase.
    • The green TRY button in the PatternDepot will download the file.
    • A download link is available in your Customer Account, once it is activated.

Install requires that you run a program or file. Here are some facts about installs:

  • Installation of Designer software has it’s own installation instructions. Go here for Designer Quick Start Guide Installation Instructions (PDF)
  • Customers using Windows Vista, 7 or 8 must use the RUN AS ADMINISTRATOR command when opening their Designer software by right-clicking on the icon and selecting RUN AS ADMINISTRATOR when installing Designer software (not patterns).
  • If you have multiple versions of software on your machine, double clicking on a .ptn, .mpn or .mpc will open the last version that was installed.

INSTRUCTIONS

SELECT THE TYPE OF PRODUCT YOU PURCHASED TO SEE THE STEP-BY-STEP INSTRUCTIONS:

Add-On SOFTWARE:

Add-on software modules include Centerline Text, Conforming Vectors, Key-Hole Function, DXF Importer, STL Importer, Pattern Editor, Vector Drawing Suite, and the Pattern Modeling Suite.

ACTIVATION – REQUIRED:
All of our premium software features must be activated before it can be uploaded to a card.

DOWNLOAD – MAY NOT BE REQUIRED:
Since, these features are already built into the basic CarveWright Designer software, there is no software download or installation needed, unless you are running an outdated version of the software.

INSTALL – MAY NOT BE REQUIRED:

Since, these features are already built into the basic CarveWright Designer software, there is no software download or installation needed, unless you are running an outdated version of the software.

Installation of Designer software has it’s own installation instructions. Go here for Designer Quick Start Guide Installation Instructions (PDF)

 

ACTIVATION INSTRUCTIONS:

Registering Through Project Designer Software (Suggested option)

  1. Open the basic CarveWright Designer software package, using the icon on your computer desktop.
    REMEMBER: IF YOU ARE USING ANY WINDOWS OPERATING SYSTEM OTHER THAN XP, you will need to open Project Designer by right-clicking on the icon and selecting RUN AS ADMINISTRATOR when activating a new license! This assures that the licenses go into the correct location.
  2. In the software, go to HELP > MANAGE LICENSES (The “Your Licenses” dialog box should appear. It shows all feature/pattern licenses currently registered to the computer.)
  3. Click on the “ACTIVATE LICENSE” button at the bottom of the “Your License” dialog box. (A new window will appear, giving you different registration options.)
  4. Select “LICENSE ONLINE NOW” (suggested option) or “LICENSE FROM ANOTHER COMPUTER” (use only if this computer does not have internet connectivity).
    1. Licensing Online Now (Suggested option)
      1. If you are connected to the Internet, select the option to “License Online Now”, and then click on the “Next” button.
      2. Enter the serial number that you received either by email. (Example: XXXX.XXXX.XXXX.XXXX)**
      3. Enter the username and password associated with the Customer Account, if prompted. This may be a different username & password than you used to order Do not use the Store Account, as the two accounts are separate.
      4. Click on the “Next” button. The software will then connect to the registration server.
      5. If the process is successful, you will see a “Thank You” message. Click on the “Finish” button in this window to finish the activation process. ACTIVATION COMPLETE
    2. Licensing From Another Computer If the computer that you are on does not have internet access, you may register the software from another computer. This process takes a little more time, but the results will be the same as if you registered it online immediately through the software. The following procedure will guide you through the process of registering the feature from another computer.
      1. Select the option to “License at www.carvewright.com from another computer”, and click on the “Next” button.
      2. Go to a computer that does have Internet access, and visit www.carvewright.com.
      3. On the main page of the CarveWright website, click on the “Customer Login” option in the top right-hand corner.
      4. You will be taken to the “Customer Login” page.
      5. Enter the account username and password, and click on the “Login” button.
      6. Once logged in, you will see two boxes: “Enter Activation or Serial Number Here:” and “Enter subscription activation code here:”. You will need the one asking for the “activation or Serial number”. Disregard the box asking for the subscription code.
      7. Enter the serial number that you received on either the email from your purchase.
      8. Click on the “Activate” button to add the feature to the account.
      9. Once added to the account, scroll down the page a bit. You will see a list of computers that are registered to the account. You should see the one that you want the software added to. Click on the checkbox below this computer to add the license to the computer.
      10. After adding the license, you will need to download the license file. Scroll down to the bottom of the page. You will see an option that says “Download License File”. Download the license file and save it to a removable media drive or disc. DO NOT CHANGE THE FILE EXTENSION!
      11. Once downloaded and saved, take the device holding the file to back to your computer. The “Registration” dialog box should still be open. Click on the button that says “Import License File”.
      12. Browse to the media device that the license file is saved to. Click on the file to select it, then click open.
      13. The software will install all licenses from the license file.
      14. Once completed, you should receive a message stating that it was successful. Click on the “Finish” button to finish the activation process. ACTIVATION COMPLETE

Please note that this feature is an add-on feature that can only be activated on two computers registered to one account, and it is non-transferable.

*Note: If you do not have a “Manage License” option listed in the “Help” menu, you may be running an outdated version of the software. In this case, you must update the software to the newest version before the feature can be registered. Please contact us for the proper software update procedure.

**Note: The feature serial number is case sensitive. You must type it exactly as it appears in the email that you received when you made your purchase. All letters should be capitalized. Failure to type the serial number exactly as it appears will result in a licensing failure.

PATTERNS:

The patterns that are available on our online store behave the same way as the patterns in the “Basic” pattern library within the software. Once downloaded and installed, they function the exact same way, except for the fact that they are stored in the “Favorites” folder in the pattern library instead of the “Basic” folder.

ACTIVATION – REQUIRED:
All patterns from the PatternDepot must be activated before it can be uploaded to a card. They will show a red background in the Pattern Library, if not yet activated.

DOWNLOAD – REQUIRED:
There are several ways to download a pattern file – TRY button on Pattern Depot, download link via email, download link in Customer Account.

INSTALL – REQUIRED:
Patterns must be installed into your Pattern Library before you can use them in your project design.

 

ACTIVATING THE PATTERN:

The following procedure will walk you through registering/activating the pattern.

  1. Open the CarveWright Designer software package, using the icon on your computer desktop.
    REMEMBER: IF YOU ARE USING ANY WINDOWS OPERATING SYSTEM OTHER THAN XP, you will need to open Project Designer by right-clicking on the icon and selecting RUN AS ADMINISTRATOR when activating a new license! This assures that the licenses go into the correct location.
  2. Select the “Manage License” option from the “Help” menu.
  3. The “Your Licenses” dialog box will appear, showing all the licenses that are currently installed/activated on your computer.
  4. Click on the “Activate Licenses” button at the bottom of the window.
  5. A “Registration” dialog box will appear, giving you two options for register:
    1. *Suggested Option – Licensing Online Now:
      1. If you are connected to the Internet, select the option to “License Online Now”, and then click on the “Next” button.
      2. Enter the serial number that you received either by email. (Example: XXXX.XXXX.XXXX.XXXX)*Enter the username and password associated with the user account, if prompted. Do not use the store account, as the two accounts are separate.
      3. Click on the “Next” button. The software will then connect to the registration server.
      4. If the process is successful, you will see a “Thank You” message. Click on the “Finish” button in this window to finish the activation process. ACTIVATION COMPLETE
    2. * Other Option – Licensing from another computer: If the computer that you are on does not have internet access, you may register the software from another computer. This process takes a little more time, but the results will be the same as if you registered it online immediately through the software. The following procedure will guide you through the process of registering the feature from another computer.
      1. Select the option to “License from another computer”, and click on the “Next” button.
      2. Go to a computer that does have Interne access, and visit www.carvewright.com.
      3. On the main page of the Carvewright website, click on the “Customer Login” option in the top right-hand corner.
      4. You will be taken to the “Customer Login” page.
      5. Enter the account username and password, and click on the “Login” button.
      6. Once logged in, you will see two boxes: “Enter Activation or Serial Number Here:” and “Enter subscription activation code here:”. You will need the one asking for the “activation or Serial number”. Disregard the box asking for the subscription code.
      7. Enter the serial number that you received on either the email from your purchase. Click on the “Activate” button to add the feature to the account.
      8. Once added to the account, scroll down the page a bit. You will see a list of computers that are registered to the account. You should see the one that you want the software added to. Click on the checkbox below this computer to add the license to the computer.
      9. After adding the license, you will need to download the license file. Scroll down to the bottom of the page. You will see an option that says “Download License File”. Download the license file and save it to a removable media drive or disc. DO NOT CHANGE THE FILE EXTENSION!
      10. Once downloaded and saved, take the device holding the file to back to your computer. The “Registration” dialog box should still be open. Click on the button that says “Import License File”.
      11. Browse to the media device that the license file is saved to. Click on the file to select it, then click open.
      12. The software will install all licenses from the license file.
      13. Once completed, you should receive a message stating that it was successful. Click on the “Finish” button to finish the activation process. ACTIVATION COMPLETE

DOWNLOAD & INSTALL INSTRUCTIONS:

  1. Click on the download link in the email that you received from your purchase to initiate the pattern download.
    If you have already downloaded by using the green TRY button in the PatternDepot, then you do not need to repeat the download & install instructions.
  2. You will be prompted to select either “Open” or “Save” the file.
    1. Opening the file: Use the instructions below if you are prompted to open the file.
      1. If you are prompted to open, click on the “Open” button to open the file. The Carvewright Designer software will open, showing the pattern in the “Import Image” dialog box.
      2. If no changes are required, click on the “Finish” button to continue the import.
      3. The “Save” item dialog box will appear, prompting you to select where to save the pattern within the Carvewright software pattern library. Select the location you would like the pattern saved to in the pattern library, then click “Save”.
      4. You will be taken back to the Carvewright software, and the pattern will be located in the location that you specified.
    2. Saving the file: Use the instructions below if you are prompted to save the file.
      1. If you are prompted to save the file, select a location where the file is going to be easily accessible, such as the computer desktop.
      2. Click “Save” to save the file to the specified location.
      3. Once saved, close out of the browser, and browse to the location where the pattern was saved.
      4. Double-click on the file to open it.
      5. The Carvewright Designer software will open, showing the pattern in the “Import Image” dialog box.
      6. If there are no changes needed to the pattern, click on the “Finish” button to continue the import.
      7. The “Save” item dialog box will appear, prompting you to select where to save the pattern within the Carvewright software pattern library. Select the location you would like the pattern saved to in the pattern library, then click “Save”.
      8. You will be taken back to the Carvewright software, and the pattern will be located in the location that you specified.

After the patterns have been fully registered, downloaded and installed, you will have full use of them. You will not be able to edit or make changes to the artwork itself, but you will be able to manipulate and resize the patterns to any size that you desire.

PATTERN COLLECTIONS:

Pattern collections are groups of patterns that have been collected into one file. Pattern collections can have any amount of patterns of a specific type. For example, there is a collection of angel patterns for sell on the online store. These patterns can be purchased individually, or as a group of patterns in a collection. The pattern collections are saved in the pattern library within the software as well. Instead of being saved into the “Favorites” section of the pattern library, a new section with the name of the collection is created, and the patterns are stored in this new section within the pattern library. Installing a pattern collection is a much more different process than installing one individual pattern.

ACTIVATION – REQUIRED:
All pattern collections (libraries) from the PatternDepot must be activated before it can be uploaded to a card. They will show a red background in the Pattern Library, if not yet activated.

DOWNLOAD – REQUIRED:
There are several ways to download a collection file – TRY button on Pattern Depot, download link via email, download link in Customer Account.

INSTALL – REQUIRED:
Pattern collections must be installed into your Pattern Library before you can use them in your project design.

 

ACTIVATING THE COLLECTION:

The following procedure will walk you through registering/activating the pattern collection.

  1. Open the CarveWright Designer software package, using the icon on your computer desktop.
    REMEMBER: IF YOU ARE USING ANY WINDOWS OPERATING SYSTEM OTHER THAN XP, you will need to open Project Designer by right-clicking on the icon and selecting RUN AS ADMINISTRATOR when activating a new license! This assures that the licenses go into the correct location.
  2. Select the “Manage License” option from the “Help” menu.
  3. The “Your Licenses” dialog box will appear, showing all the licenses that are currently installed/activated on your computer.
  4. Click on the “Activate Licenses” button at the bottom of the window.
  5. A “Registration” dialog box will appear, giving you two ways to register: “License Online Now” or License at www.carvewright.com from another computer”.
    1. Licensing Online Now (suggested option): 
      1. If you are connected to the Internet, select the option to “License Online Now”, and then click on the “Next” button.
      2. Enter the serial number that you received either by email. (Example: XXXX.XXXX.XXXX.XXXX)*
      3. Enter the username and password associated with the user account, if prompted. Do not use the store account, as the two accounts are separate.
      4. Click on the “Next” button. The software will then connect to the registration server.
      5. If the process is successful, you will see a “Thank You” message. Click on the “Finish” button in this window to finish the activation process. ACTIVATION COMPLETE
    2. Licensing from another computer:If the computer that you are on does not have internet access, you may register the collection from another computer. This process takes a little more time, but the results will be the same as if you registered it online immediately through the software. The following procedure will guide you through the process of registering the collection from another computer.
      1. Select the option to “License at www.carvewright.com from another computer”, and click on the “Next” button.
      2. Go to a computer that does have Internet access, and visit www.carvewright.com.
      3. On the main page of the Carvewright website, click on the “Customer Login” option in the top right-hand corner.
      4. You will be taken to the “Customer Login” page.
      5. Enter the account username and password, and click on the “Login” button.
      6. Once logged in, you will see two boxes: “Enter Activation or Serial Number Here:” and “Enter subscription activation code here:”. You will need the one asking for the “activation or Serial number”. Disregard the box asking for the subscription code.
      7. Enter the serial number that you received on either the email from your purchase. Click on the “Activate” button to add the feature to the account.
      8. Once added to the account, scroll down the page a bit. You will see a list of computers that are registered to the account. You should see the one that you want the software added to. Click on the checkbox below this computer to add the license to the computer.
      9. After adding the license, you will need to download the license file. Scroll down to the bottom of the page. You will see an option that says “Download License File”. Download the license file and save it to a removable media drive or disc. DO NOT CHANGE THE FILE EXTENSION!
      10. Once downloaded and saved, take the device holding the file to back to your computer. The “Registration” dialog box should still be open. Click on the button that says “Import License File”.
      11. Browse to the media device that the license file is saved to. Click on the file to select it, then click open.
      12. The software will install all licenses from the license file.
      13. Once completed, you should receive a message stating that it was successful. Click on the “Finish” button to finish the activation process. ACTIVATION COMPLETE

DOWNLOAD & INSTALL INSTRUCTIONS:

  1. Click on the link in the email that you received from your purchase to initiate the pattern collection download.
  2. You will be prompted to either “Open” or “Save” the file.
    1. Opening the file:
      1. If you are prompted to open, click on the “Open” button to open the file.
      2. The “Registration/Install Collection” dialog box will open, presenting you with two options: “I have purchase this collection” and “I have not yet purchased this collection”.
      3. Highlight the option stating that you have purchased the collection, then click on the “Next” button.
      4. Select the option to license online and click “Next”. You may also select the option to license from another computer.**
      5. The “Online Registration” window will appear. Enter the serial number that you received in the email from your purchase. (Example: XXXX.XXXX.XXXX.XXXX)
      6. Enter the username and password associated with your customer account, if prompted. Do not use the store account login, as it is a separate login and will not work for the registration process.
      7. Click on the “Next” button to submit the information to the online server. If the process is successful, you will receive a message stating that the collection has been installed and registered. Click on the “Finish” button to finish the installation/activation process.
    2. Saving the file:
      1. If you are prompted to save the file, select a location where the file is going to be easily accessible, such as the computer desktop.
      2. Click “Save” to save the file to the specified location.
      3. Once saved, close out of the browser, and browse to the location where the pattern was saved.
      4. Double-click on the file to open it.
      5. The “Registration/Install Collection” dialog box will open, presenting you with two options: “I have purchase this collection and need to activate the software serial number.” or “I do not need to activate this collection. It is already licensed or I just want to try it before I buy.”.
      6. Highlight the second option, NEXT & FINISH.

After the patterns have been fully registered, downloaded and installed you will have full use of them. You will not be able to edit or make changes to the artwork itself, but you will be able to manipulate and resize the patterns to any size that you desire.

PROJECTS:

Projects are completed MPC files that have been fully designed in the software, and then submitted for purchase. They come with all the MPC files needed to carve the project, as well as detailed instructions on how to assemble the carved items. They come in a zipped file format, and are not saved in the pattern library, as the patterns and collections are. You will need to unzip the purchased projects into a folder that you specify, and register them, before you can upload them to your memory card. The following procedure will guide you through downloading/registering/opening the purchased project.

ACTIVATION – REQUIRED:
All projects from the PatternDepot must be activated before it can be uploaded to a card.
EXCEPTION: Projects received as part of the Project of the Month Subscription are already activated to your Customer Account. You will only need to UPDATE LICENSES and download the project.

DOWNLOAD – REQUIRED:
There are several ways to download a project file – TRY button on Pattern Depot, download link via email, download link in Customer Account.

INSTALL – NOT REQUIRED:
Projects should be stored on your computer and are not put into the Pattern Library. You will only OPEN project files.

ACTIVATING THE PROJECT:

Before you are able to open the project files, they must first be licensed. The licensing procedure adds the licenses needed for all components on the project. You may use the directions below to register the project.

  1. Open the Carvewright software and select the “Manage License” option from the “Help” menu.
  2. The “Your Licenses” dialog box will appear, showing all the licenses that are currently installed/activated on your computer. Click on the “Activate Licenses” button at the bottom of the window.
  3. A “Registration” dialog box will appear, giving you two ways to register: “License Online Now” or License at www.carvewright.com from another computer”.
    1. Licensing Online Now (suggested option):
      1. If you are connected to the Internet, select the option to “License Online Now”, and then click on the “Next” button.
      2. Enter the serial number that you received either by email. (Example: XXXX.XXXX.XXXX.XXXX)*
      3. Enter the username and password associated with the user account, if prompted. Do not use the store account, as the two accounts are separate.
      4. Click on the “Next” button. The software will then connect to the registration server.
      5. If the process is successful, you will see a “Thank You” message. Click on the “Finish” button in this window to finish the activation process. ACTIVATION COMPLETE
    2. Licensing from another computer: If the computer that you are on does not have internet access, you may register the software from another computer. This process takes a little more time, but the results will be the same as if you registered it online immediately through the software. The following procedure will guide you through the process of registering the feature from another computer.
      1. Select the option to “License at www.carvewright.com from another computer”, and click on the “Next” button.
      2. Go to a computer that does have Internet access, and visit www.carvewright.com.
      3. On the main page of the Carvewright website, click on the “Customer Login” option in the top right-hand corner.
      4. You will be taken to the “Customer Login” page.
      5. Enter the account username and password, and click on the “Login” button.
      6. Once logged in, you will see two boxes: “Enter Activation or Serial Number Here:” and “Enter subscription activation code here:”. You will need the one asking for the “activation or Serial number”. Disregard the box asking for the subscription code.
      7. Enter the serial number that you received on either the email from your purchase. Click on the “Activate” button to add the feature to the account.
      8. Once added to the account, scroll down the page a bit. You will see a list of computers that are registered to the account. You should see the one that you want the software added to. Click on the checkbox below this computer to add the license to the computer.
      9. After adding the license, you will need to download the license file. Scroll down to the bottom of the page. You will see an option that says “Download License File”. Download the license file and save it to a removable media drive or disc. DO NOT CHANGE THE FILE EXTENSION!
      10. Once downloaded and saved, take the device holding the file to back to your computer. The “Registration” dialog box should still be open. Click on the button that says “Import License File”.
      11. Browse to the media device that the license file is saved to. Click on the file to select it, then click open.
      12. The software will install all licenses from the license file.
      13. Once completed, you should receive a message stating that it was successful. Click on the “Finish” button to finish the activation process. ACTIVATION COMPLETE

DOWNLOADING THE PROJECT:

After the project files have been registered, you will be able to open the files. The procedure listed below will walk you through downloading and opening the project files.

  1. Click on the download link in the email that you received from your purchase to initiate the project download.
  2. You will be prompted to either “Open” or “Save” the file.
  3. Save the file to a location that is easily accessible on your computer, such as the desktop.
  4. After the download has completed, browse to where the file is saved.
  5. It will be a zipped file, so you will need to unzip it. The process will vary between Windows and Mac operating systems.
    1. On a Windows based pc, right-click the file. You should see an “Extract” option. Click the “Extract” option and follow the onscreen prompts.
    2. On a Mac based computer, save the file to the location that you prefer on your system. Double-click the file and the operating system will automatically extract the files.
  6. Once the folder has been unzipped, double-click it to view the contents.
  7. You should see the project (MPC) files, as well as the instructions, which will be in a PDF file format.
  8. Open each of the project files by clicking on it. They will open in the Carvewright software.
  9. Once opened, select “Upload” from the “File” menu to upload the project to the card.

The procedures listed above work for all of the operating systems that we currently support. If for some reason you encounter issues during any of these process, or you have questions regarding a process, please contact us and we will gladly assist further.

SUBSCRIPTIONS:

Subscriptions are good for one year, and each month you will receive an email about that subscription. There are currently two different subscriptions available: “Project of the Month” and the “Carver’s Club” subscriptions. These are two separate subscriptions and purchasing one does not entitle you to the other.

The “Project of the Month” subscription gives you a project each month. One price for the subscription gets you 12 projects at a greatly reduced price than available to non-members. The projects are specially designed and crafted for us, with each month being a new and exciting the project.

The “Carver’s Club” subscription is a yearly subscription for phone support. If you are out of warranty, there is an issue fee each time you call in for support. The Carver’s Club subscription takes care of that buy covering the issue fees for a year. It also includes 12 monthly exclusive offers to members, such as free pattern, discounts on software packages, or discounts on accessories. There is also a 25% discount on labor, if you should have to send in your machine for repair. It does not cover the cost of parts that may be needed for those repairs. The subscription also offers complementary testing of your parts.

Subscriptions are accumulative. If you have 3 months left in that years subscription and activate a new subscription, you will then have 15 months of subscriptions.

ACTIVATION – REQUIRED:
All subscriptions must be activated before it can be uploaded to a card. MAKE SURE you use the ACTIVATE SUBSCRIPTION link and not the Activate License link.

DOWNLOAD – MAY BE REQUIRED:
There is not a download for activation of your subscription. However, there will be one for the Project of the Month and sometimes for the CarversClub. If there is a downloadable file, the email will include a link or you can get it from your Customer Account. Follow the instructions per that product.

INSTALL – MAY BE REQUIRED:
Install is required only if there is a downloadable file sent to you via email. Follow the instructions per that product.

Activating the Project:

Once you purchase either of these subscriptions, you must activate it in order to receive the benefits. The following process will guide you step by step through the registration procedure.

  1. Open the basic Carvewright Designer software package, using the icon on your computer desktop.
  2. In the software, select the “Manage Licenses” option from the software’s “Help” menu.*
  3. The “Your Licenses” dialog box should appear. It shows all feature/pattern licenses currently registered to the computer.
  4. Click on the “Activate Subscription” button at the bottom of the “Your License” dialog box.
  5. A new window will appear, giving you different registration options: “License Online Now” or “License from another Computer”.
    1. Licensing Online Now (Suggestion Option)
      1. If you are connected to the Internet, select the option to “License Online Now”, and then click on the “Next” button.
      2. Enter the subscription serial number that you received either by email. (Example: XXXX.XXXX.XXXX.XXXX)**
      3. Enter the username and password associated with the user account, if prompted. Do not use the store account, as the two accounts are separate.
      4. Click on the “Next” button. The software will then connect to the registration server.
      5. If the process is successful, you will see a “Thank You” message. Click on the “Finish” button in this window to finish the activation process. ACTIVATION COMPLETE
    2. Licensing From Another Computer If the computer that you are on does not have internet access, you may register the software from another computer. This process takes a little more time, but the results will be the same as if you registered it online immediately through the software. The following procedure will guide you through the process of registering the feature from another computer.
      1. Select the option to “License at www.carvewright.com from another computer”, and click on the “Next” button.
      2. Go to a computer that does have Internet access, and visit www.carvewright.com.
      3. On the main page of the Carvewright website, click on the “Customer Login” option in the top right-hand corner.
      4. You will be taken to the “Customer Login” page.
      5. Enter the account username and password, and click on the “Login” button.
      6. Once logged in, you will see two boxes: “Enter Activation or Serial Number Here:” and “Enter subscription activation code here:”. You will need the one asking for the “Subscription Serial Number”. Disregard the box asking for the activation ID/serial number.
      7. Enter the serial number that you received on either the email from your purchase.
      8. Click on the “Activate” button to add the feature to the account.
      9. Once added to the account, scroll down the page a bit. You will see a list of computers that are registered to the account. You should see the one that you want the software added to. Click on the checkbox below this computer to add the license to the computer.
      10. After adding the license, you will need to download the license file. Scroll down to the bottom of the page. You will see an option that says “Download License File”. Download the license file and save it to a removable media drive or disc. DO NOT CHANGE THE FILE EXTENSION!
      11. Once downloaded and saved, take the device holding the file to back to your computer. The “Registration” dialog box should still be open. Click on the button that says “Import License File”.
      12. Browse to the media device that the license file is saved to. Click on the file to select it, then click open.
      13. The software will install all licenses from the license file.
      14. Once completed, you should receive a message stating that it was successful. Click on the “Finish” button to finish the activation process. ACTIVATION COMPLETE

*Note: If you do not have a “Manage License” option listed in the “Help” menu, you may be running an outdated version of the software. In this case, you must update the software to the newest version before the feature can be registered. Please contact us for the proper software update procedure.

**Note: The subscription serial number is case sensitive. You must type it exactly as it appears in the email. All letters should be capitalized. Failure to type the subscription serial number exactly as it appears will result in a licensing failure.

If you encounter any issues during the activation process, or you have questions regarding the process or the subscriptions themselves, feel free to contact us and we will gladly assist/answer any questions that you may have.


Remember you made a purchase through your Store Account and that username & password MAY BE DIFFERENT than the username & password for your Customer Account, where it will be activated.